4791: Lost Townsfolk of Bran Llyr step #3

Reported by ☆ b12d at Tue, 10 Jul 2018 00:14:24 UTC
worldbuild bug
5 votes


Epic quest Lost Townsfolk of Bran Llyr step 3 for my Ranger I am asked to go to Lough Gur and find the Siabra Gurite Tiomoid. Ask him about the [lost townsfolk].

Tiomoid is hostile surrounded by agro mobs, I cleared everything around him to be able to talk to him. I said in /say lost townsfolk, and also I tried it in a /whisper just in case that worked. Agro mobs popped and I had to run away. Came back with a friend to clear the agro. Spoke to him again, also trying /say sympathy as that was posted on Zam to work if Tiomoid did not respond to me. This did not work either. Stuck on step 3, quest will not advance.

Reproduction Steps

1. Talk to Tiomoid /say lost townsfolk, per the quest he is supposed to respond
2. One might have to clear agro mobs. Tiomoid is yellow to my 41 Ranger, other mobs in the camp are mostly green with some blues.
3. It is posted on Zam to /say sympathy if Tiomoid does not respond to you. This did not work for me.

Intended Behavior

When standing in front of Tiomoid and having him targeted I should be able to /say lost townsfolk, so that he responds to me and gives me the next step (#4) in the quest line.


NPC will not talk to me when I /say lost townsfolk. This is what my quest journal tells me to do. Quest will not update to the next step in the Ranger epic line. Zam says to /say sympathy if he does not respond to me. This did not work either.
I left and came back to him and Tiomoid will still not speak to me.


issue has been confirmed
votes (priority): 5
6 players say this report is valid, 0 disagree


Note: You need to be logged in to post comments.
Loading Comments...